windows 10 安装 Kautilya

作者: admin 分类: 未分类 发布时间: 2016-06-06 00:29

1、Kautilya 使用 Ruby 编写,因此需要先安装 Ruby 运行环境。到这里下载安装 1.9.3 版(由于对 Win32Console 的依赖,不要安装2.0或以上版本)。
1.9.3 ruby 下载 http://rubyinstaller.org/downloads/archives

2、下载修改过的 Kautilya https://github.com/harnnless/Kautilya/archive/master.zip
或 git clone https://github.com/harnnless/Kautilya.git

3、安装所需

gem install bundler  
gem install highline -v 1.6.21
gem install artii -v 2.0.4
gem install colored -v 1.2
gem install win32console -v 1.3.2   // 仅 Windows 下需要

不安装bundler 可能会报如下错误:

d:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file -- bundler/setup (LoadError)
        from d:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from C:/Users/lili/Documents/GitHub/Kautilya/kautilya.rb:3:in `
'

建议gem使用 taobao 源

标签云